New knock sensors and now no start...

Discussion in 'Engine & Drivetrain' started by aces-n-eights, May 17, 2018.

  1. aces-n-eights

    aces-n-eights Member

    Posts:
    68
    Likes Received:
    34
    Joined:
    May 18, 2016
    Location:
    Alaska
    Name:
    Wayne
    2006 Tahoe, 5.3. I got a CEL a few months back that the knock sensors were a pending code. Replaced them today and now the truck won't start.

    I'm getting the following codes.

    P0068 Powertrain
    P0107 Manifold Pressure/Barometric Pressure circuit low input
    P0332 Knock Sensor 2 Circuit Low Input, Bank 2

    The truck only cranks and no start. The DIC says "Reduced Engine Power".

    So I'm wondering if I forgot to plug something back in, but I've triple checked and there are no loose wires or connectors.

    Any suggestions?
    Thanks guys!
     
  2. aces-n-eights

    aces-n-eights Member

    Posts:
    68
    Likes Received:
    34
    Joined:
    May 18, 2016
    Location:
    Alaska
    Name:
    Wayne
    OK, figured it out, cleared the codes and it started right up. Sorry to bother y'all!
     
  3. Tonyrodz

    Tonyrodz Full Access Member

    Posts:
    8,393
    Likes Received:
    7,175
    Joined:
    Feb 16, 2012
    Location:
    Central Jersey
    Name:
    Tony
    What was the issue?
     
  4. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    633
    Likes Received:
    431
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    only thing i can think of is he powered the key while it was all apart. pcm saw all them things missing and set codes.

    id crap my pants a bit too if that happened to me.....
     
    aces-n-eights and Tonyrodz like this.
  5. aces-n-eights

    aces-n-eights Member

    Posts:
    68
    Likes Received:
    34
    Joined:
    May 18, 2016
    Location:
    Alaska
    Name:
    Wayne
    That's exactly what happened. And yes, I'm a dumbass. I'd surely starve if I had to make a living as a mechanic!
     
    HiHoeSilver likes this.
  6. Tonyrodz

    Tonyrodz Full Access Member

    Posts:
    8,393
    Likes Received:
    7,175
    Joined:
    Feb 16, 2012
    Location:
    Central Jersey
    Name:
    Tony
    Happens to the best of us. At least you resluzed what happened.
     
  7. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    633
    Likes Received:
    431
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott

    hey at least you have a scanner to read and then clear codes. so many dont have even the cheapest of scanners.

    i got a 15 dollar actron years ago. it lives in my console. never know when your gonna need it.
     
    HiHoeSilver likes this.
  8. aces-n-eights

    aces-n-eights Member

    Posts:
    68
    Likes Received:
    34
    Joined:
    May 18, 2016
    Location:
    Alaska
    Name:
    Wayne
    Thanks. And yes, my OBD scanner is in my center console.

    Just for grins I thought I'd show a pic of the old sensors next to the new ones.

    [​IMG]
     
    HiHoeSilver likes this.
  9. Doubeleive

    Doubeleive Elite Member Supporting Member

    Posts:
    2,026
    Likes Received:
    1,105
    Joined:
    Nov 7, 2017
    Location:
    Stockton, Ca.
    Name:
    Wes
    true I was having intermittent transmissions problems once, stupid trans would error out and sit dead in the water (no go), clear the code and you could go again until it would error out again, my little actron stays in the truck at all times now
     
  10. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    633
    Likes Received:
    431
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott

    both under water. great design.
     

Share This Page