Mystery Cold Leak

Discussion in 'Engine & Drivetrain' started by supergreen, Dec 6, 2017.

  1. supergreen

    supergreen TYF Newbie

    Posts:
    3
    Likes Received:
    0
    Joined:
    Jan 9, 2012
    Name:
    Lincoln
    I have a 96 Tahoe, 5.7, 4wd, 100k. The past few weeks it has had a drip of coolant resulting in an area about the size of a paper plate. Does not drip until motor cools off. I took it to local place and they pressure tested it but no leaks. let off pressure and discovered clamp on bottom hose loose enough for seepage when motor not running. Went a few days and leak is back. took it again , kept it overnight and discovered next day clamps on bypass to water pump loose, tightend them and all is well for about 2 days and leak is back. Temp remains normal. Driving me crazy!!! I cannot tell where it is coming from under neath but it collects on harmonic balancer. Any suggestions/help would be much appreciated!
    Thank you
     
  2. TigerEyz3

    TigerEyz3 Slow and Steady

    Posts:
    610
    Likes Received:
    22
    Joined:
    Feb 11, 2010
    Location:
    TN
    Name:
    Robert
    Could be the water pump hoses that haven't been tightened, could be the bypass hoses on the water pump, could be the water pump itself (weeping). Those are the only things above the harmonic balancer on the front end....unless things are getting into big money (intake gaskets).
     
  3. supergreen

    supergreen TYF Newbie

    Posts:
    3
    Likes Received:
    0
    Joined:
    Jan 9, 2012
    Name:
    Lincoln
    Would weeping happen with pressure tester? I did an oil check for intake but will look closer at the front.
    Thank you for the input.
     
  4. east302

    east302 Full Access Member

    Posts:
    391
    Likes Received:
    101
    Joined:
    Dec 21, 2016
    Location:
    Mississippi
    Name:
    east302
    Could also be thermostat housing/hose leaking.
     

Share This Page