Lost of power

Discussion in 'Engine & Drivetrain' started by marc2004, Mar 20, 2017.

  1. marc2004

    marc2004 TYF Newbie

    Posts:
    7
    Likes Received:
    2
    Joined:
    Apr 21, 2016
    Name:
    Marcus
    Ive been having an issue with my truck. Bought a new battery for it. Truck sat for about 2 weeks. Went out to start it the battery was dead. Hooked cables to it fired right with in seconds of the cables being on. Let the battery charge. Same thing keeps happening. Recently I was driving down the road and it lost complete power. What is my problem?
     
  2. Galante

    Galante Elite Member Supporting Member

    Posts:
    5,043
    Likes Received:
    3,269
    Joined:
    Nov 6, 2016
    Location:
    NY
    Name:
    Pete
    Check, double check, and triple check all your grounds
     
  3. Brian Wilson

    Brian Wilson Full Access Member

    Posts:
    372
    Likes Received:
    118
    Joined:
    Feb 16, 2016
    Name:
    Brian
    Keep it simple. Test battery and alternator
     
  4. Galante

    Galante Elite Member Supporting Member

    Posts:
    5,043
    Likes Received:
    3,269
    Joined:
    Nov 6, 2016
    Location:
    NY
    Name:
    Pete
    Well, i said grounds because he bought a new battery and if it was the alt he'd be running on the battery and then when you go to jump it it wouldn't 'fire right up' like he said. in my experience if a battery is bad, it takes a while to jump. losing power while driving, to me, would be something loose. Just my thoughts. Correct me if im wrong.
     
    rockola1971 likes this.
  5. SnowDrifter

    SnowDrifter Full Access Member

    Posts:
    209
    Likes Received:
    70
    Joined:
    Sep 5, 2016
    Location:
    Wa
    Name:
    Chris
    You lost electrical power while driving?

    What voltage does your alternator charge at? What about current when load tested?
     

Share This Page