Front end squeak

Discussion in 'Lifted Supension - Z71 & 4x4' started by Govtahoe, Mar 19, 2017 at 8:00 PM.

  1. Govtahoe

    Govtahoe Member

    Posts:
    36
    Likes Received:
    4
    Joined:
    Jul 3, 2014
    Name:
    Will
    Every time I hit a bump my front end squeaks. When I turn at low speeds it squeaks for the duration of the turn. I've looked everything over multiple times. Tried adjusting the tightness of the bolts on the UCAs and it didn't help. I can't find anything to make it stop. The turning made me think it may have been power steering but it's got plenty of fluid and everything looks fine. I had a 3.5" rough country lift put on in August but it seems too delayed to be an issue from that. I'm at a complete loss. Any help would be appreciated.


    Sent from my iPhone using Tapatalk
     
  2. Tractoman

    Tractoman TYF Newbie

    Posts:
    8
    Likes Received:
    0
    Joined:
    Mar 1, 2017
    Name:
    Mike
    CV's maybe?
     
  3. 01Konvict

    01Konvict Boats n Hoes

    Posts:
    2,176
    Likes Received:
    332
    Joined:
    Jan 16, 2011
    Location:
    Raleigh/SML
    Name:
    Wade
    Probably upper control arm bushings. There polyurethane so have to grease the hell out of them. Outside and inside plus inside holes, basically dunk them in grease and smear all over them then install. I had some squeak on my rear ones and did the same no more squeak.
     
  4. Govtahoe

    Govtahoe Member

    Posts:
    36
    Likes Received:
    4
    Joined:
    Jul 3, 2014
    Name:
    Will
    I appreciate the quick responses. My CVs seem fine. No clicking or vibration. Passenger side is slinging grease for some reason. Going to have to look into that. I'll get some lithium grease and hose the UCA bushings down. 01Konvict, I swear you're on every post in this forum. Thanks for always sharing your knowledge.


    Sent from my iPhone using Tapatalk
     
    01Konvict likes this.
  5. sumo

    sumo dn ʇǝƃ ʇuɐɔ & llǝɟ ı

    Age:
    36
    Posts:
    5,105
    Likes Received:
    347
    Joined:
    May 21, 2010
    Location:
    rhode island
    Name:
    ian
    Try lower ball joints? When mine were going, they make a creek sound. Could make it happen just by turning side to side. If you jack up he front tire off the ground, stick a pry bar between the tire and ground and pry up. Mine had a lot of play.
    Also these oem joints are not greeaseable. What I also done in the past was grab a grease gun and got a needed attachment. Stab the boot and inject grease, turned side to side until it's quiet. When its all greased up use silicone and cover the puncture hole so it doesn't leak out.
    If you do need joints, I'd recommend using a greaseable joint like moog
     
  6. 01Konvict

    01Konvict Boats n Hoes

    Posts:
    2,176
    Likes Received:
    332
    Joined:
    Jan 16, 2011
    Location:
    Raleigh/SML
    Name:
    Wade
    No problem dude just around to help. I'm taking a shot at the squeak but I would bet its from the arms since that's the main part that's new on the front end from lift that moves constantly.
     

Share This Page