Both sets of vanity mirror lights not working?

Discussion in 'Interior' started by derekjl, Nov 12, 2017.

  1. derekjl

    derekjl Full Access Member

    Posts:
    125
    Likes Received:
    6
    Joined:
    Mar 5, 2014
    Name:
    Derek
    Noticed this a few days after buying our 1995 Tahoe. Is there a fuse that goes to these? I just find it ironic that both sets of lights are not working at all. But hey, at least the covers aren't broken yet! The passenger side one even has the factory plastic still on it.
     
  2. east302

    east302 Full Access Member

    Posts:
    360
    Likes Received:
    85
    Joined:
    Dec 21, 2016
    Location:
    Mississippi
    Name:
    east302
    Are the bulbs good?

    This is for a 98, I'd guess that it's the same for a 95.

    They are fed from the Courtesy fuse #3. Ground is #G200 which, I think, is screwed into the horizontal bar kind of behind the knee bolster air vent. Check that it's on there.

    [​IMG]

    [​IMG]

    I couldn't find a description telling where connector C271 is, but here's the view of it.

    [​IMG]

    If you find it, test the Orange (D) to a ground and see if you get voltage (12V). Then test from Orange (D) to black terminal (E) to verify that the ground is good. If both pass, then it's an issue between that connector and the visors (bad visors, bad wiring).
     
    Last edited: Nov 13, 2017
  3. derekjl

    derekjl Full Access Member

    Posts:
    125
    Likes Received:
    6
    Joined:
    Mar 5, 2014
    Name:
    Derek
    Thanks for the reply. Is this the process you are referring to?

    https://www.carcarekiosk.com/video/1999_Chevrolet_Tahoe_5.7L_V8/fuse_interior/replace
     
  4. east302

    east302 Full Access Member

    Posts:
    360
    Likes Received:
    85
    Joined:
    Dec 21, 2016
    Location:
    Mississippi
    Name:
    east302
    Sorry, I edited my post above while you were replying.

    Yes, the fuse is in that side interior fuse box. There should be a diagram on the lid identifying the fuses.

    [​IMG]

    [​IMG]
     
  5. derekjl

    derekjl Full Access Member

    Posts:
    125
    Likes Received:
    6
    Joined:
    Mar 5, 2014
    Name:
    Derek
    Ok, thanks. Now here's the thing. According to the diagram that fuse (#3) also goes for other bulbs, not just the vanity mirrors. All of them are working EXCEPT the vanity mirrors. So I am kind of stumped.
     
  6. east302

    east302 Full Access Member

    Posts:
    360
    Likes Received:
    85
    Joined:
    Dec 21, 2016
    Location:
    Mississippi
    Name:
    east302
    Assuming the bulbs are good (the lenses pop off) then I'd check for voltage at that connector (#271, I'm assuming you'll have voltage) and verify that it's grounding at that connector as well to G200.


    I'd guess that the connector is down under the driver side dash somewhere. Not sure.
     
  7. derekjl

    derekjl Full Access Member

    Posts:
    125
    Likes Received:
    6
    Joined:
    Mar 5, 2014
    Name:
    Derek
    Ok, thanks. I will investigate further at some point, not a huge deal right now. I posted another thread last night regarding a whistling noise, any input on your end would (or anyone else's) would be appreciated.
     

Share This Page